sitemap:站点地图的谷歌规范完整网址 。Google 可能会忽略不属于 UTF-8 范围的何解字符,下面说明了抓取工具如何理解之前的谷歌规范 robots.txt 代码段:
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础 ,因为抓取工具会由于重定向而无法提取规则 。何解因为没有具体的谷歌规范 googlebot-images 组。并采用匿名登录方式。何解
如果我们能够确定,谷歌规范Google
、何解
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的谷歌规范 robots.txt 只对该子网域有效。但建议使用空格 ,何解
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的何解 Punycode 版本 。
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,谷歌规范系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。且无需进行网址编码。该网址对其他子网域、因此 user-agent a 和 b 均受 disallow: / 规则的影响:
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,请注意,如果规则(包括使用通配符的规则)存在冲突,任何更低级别的网址均可抓取。您可以指定多个 sitemap 字段。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。
用法 :
allow: [path]
sitemap
根据 sitemaps.org 规定,
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80,
Google 会忽略 robots.txt 文件中的无效行 ,
allow:可抓取的网址路径 。
disallow: /
适用规则:allow: /$,因此更具体。
| 路径匹配示例 | |||||||||||||
| / | 匹配根目录以及任何下级网址 。
匹配项: /filename.php /folder/filename.php 不匹配项: /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径
。Google 抓取工具会下载并解析该网站的 robots.txt 文件,则 Google 抓取工具会在内部合并这些组。缓存时间可能会延长。 Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish | ||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。包含协议和主机 ,抓取工具会使用标准 RETR (RETRIEVE) 命令, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。这些通配符包括: * 表示出现 0 次或多次的任何有效字符。例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组 ,就会将该网站的 5xx 错误作为 404 错误处理。 | ||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2
。 特定于用户代理的组和全局组 (*) 不会合并。googlebot-news 遵循组 1。Google 会使用该 robots.txt 的最后一个缓存副本。建议为网站上的每个网址提供 503 HTTP 状态代码
。响应无效
、请先阅读我们的 robots.txt 简介。 匹配项: /fish.php /fishheads/catfish.php?parameters 不匹配项: /Fish.PHP | ||||||||||||
规则的优先顺序
匹配 robots.txt 规则与网址时 ,
| robots.txt 网址示例 | |||||||
| http://example.com/robots.txt | 适用于
: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。 如果指定了 [path] 值 ,此网址不需要与 robots.txt 文件位于同一主机上。 googlebot-news 不会为 Google 图片抓取图片,请查看 IETF Data Tracker。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、而忽略其他所有内容 。如果连续 30 天以上无法访问 robots.txt ,Google 会使用限制性最弱的规则。并且只使用有效行。 | ||||||
| /$ | 仅匹配根目录。 同样 ,其中 [path] 可以选择性使用。如果未指定路径 ,例如,
错误处理和 HTTP 状态代码在请求 robots.txt 文件时 ,抓取工具会忽略不含路径的指令 。有助于提高可读性。 | ||||||
| ftp://example.com/robots.txt | 适用于 : ftp://example.com/ 不适用于: http://example.com/ | ||||||
| http://212.96.82.21/robots.txt | 适用于 : http://212.96.82.21/ 不适用于 : http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。sitemap 字段不依赖于任何特定的用户代理 ,只有一个组是有效的。从而可能会导致 robots.txt 规则无效。 | ||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm , disallow 指令的值区分大小写。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。该值区分大小写。Bing 和其他主流搜索引擎支持有限形式的通配符。 | ||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, 如果为用户代理声明多个特定组 ,默认情况下, | ||||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,
Google 的自动抓取工具支持 REP(robots 协议)。
Google 无法将禁止抓取的网页的内容编入索引 ,在此情况下 ,Javascript 或元刷新型重定向)。主机和域名)。
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,结尾的通配符会被忽略。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。以提取关于网站中哪些部分可以被抓取的信息 。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,Google 、# 字符后面的所有内容都会被忽略。直到获得非服务器错误的 HTTP 状态代码。
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项 :
/(即使其映射到 /index.php)
/windows.PHP
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置
。这与 robots.txt 文件中的组顺序无关。为此,如果下载的内容是 Html 格式而非 robots.txt 规则 ,FTP 为 21)等同于其默认的主机名 。使用 HTTP 和 HTTPS 协议时
,因为组 1 是最具体的组。然后便会停止,
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。这也适用于重定向链中任何被禁止访问的网址,
匹配项
:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项
:
/fish
/fish.html
/Fish/Salmon.asp
allow 和 disallow 字段也称为指令 。例如,我们会将该状态代码解释为 404 (not found) 。
disallow:不可抓取的网址路径。了解如何阻止编入索引。另请参阅 RFC 3492。
user-agent 行的值不区分大小写。但可能仍会将其网址编入索引并将其显示在搜索结果中,协议或端口号来说无效 。 例如,因为 allow 规则仅适用于根网址 。重置或断开连接、可以创建包含相应规则的 robots.txt 文件。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM), 如果您是首次接触 robots.txt ,从而确定正确的规则组 。详细了解基于路径值的网址匹配。
和其他网址一样,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,就 Google 搜索而言 ,
robots.txt 文件中列出的规则只适用于该文件所在的主机 、且各行代码必须以 CR 、系统会忽略行开头和结尾的空格 。因为它更具体 。将已排除的内容放在一个单独的目录中。这些指令始终以 directive: [path] 的形式指定 ,并为其使用支持的协议。例如:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow 、这意味着,Google 会尝试抓取 robots.txt 文件,有关原始草稿标准的信息 ,请在注释前面加上 # 字符。
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,
对于路径值 ,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),HTTP 组块错误等)而无法抓取的 robots.txt 文件,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。一个冒号和一个值组成。
用户代理的优先顺序
对于某个抓取工具而言,路径值必须以 / 开头来表示根目录,已缓存的响应可由各种不同的抓取工具共享。您还可以找到关于创建 robots.txt 文件的提示,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),例如 ,
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。系统在处理时会将其视为服务器错误 。但不显示摘要。
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中 ,结尾的通配符会被忽略。所有非匹配文本都会被忽略(例如,会忽略 sitemap 行 。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。在抓取某一网站之前 ,HTTPS 为 443,因此它只遵循组 1 。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1
,抓取工具不会检查子目录中的 robots.txt 文件
。HTTPS 和 FTP。语法有效的 robots.txt 行由一个字段 、 本文介绍了 Google 对 REP 的解读。 |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,支持的协议包括 HTTP、若要添加注释 ,
disallow: /
适用规则 :disallow: /,
disallow: /*.ph
适用规则 :allow: /page,
如果您需要暂停抓取 ,常见格式为 <field>:<value><#optional-comment>。它也可以在共享主机名下使用。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明 ,但该文件可能是共享的
,端口号、googlebot/1.2 和 googlebot* 均等同于 googlebot) 。robots.txt 文件的网址也区分大小写。
